www.yaesu.com
The FT920 Resource Page

From K5NTX

Mark,

Thought I'd drop you a line regarding my FT-920. You can put it in your user comments section if you like.

I bought my FT-920 (s/n 7F020254) at the Ham-Com convention in Arlington, TX (between Dallas & Ft. Worth) during the first week of June. The only problem I've identified so far, aside from incorrect information in the manual in a few areas, is with the Noise Blanker.

I sent the unit to Yaesu for modification and just got it back on Thursday (9/11). In the limited amount of time I've played with it since it came back, it appears that the NB no longer works at all. It used to work great, except for the trash it threw into the audio. But I'm still investigating -- perhaps the "right" kind of noise hasn't been present during my evaluation.

I agree with others who have said that the SSB filter is too wide (a side note: the slope tuning on my Kenwood TS-850 is more effective with it's standard width SSB filter than the 920's DSP is on it's standard SSB filter). The 920 should have had a slot for a narrow SSB filter.

Otherwise, I think it's a great rig, though I'm still eyeing the FT-1000MP! Oh, if I were only rich.

73, Jim, KC5OA

Follow up comments from Jim (12/07/97)

Back in September (when I was still KC5OA) I sent you my comments on my FT-920. The following is an update to those comments:

As I mentioned in my previous comments, the Noise Blanker no longer worked after I got my 920 back from Yaesu in September. They apparently botched the mod because the NB no longer worked at all, and somehow was affecting the operation of the AGC circuit. I finally got around to sending the radio to them for a second attempt in mid-November and received the radio back on December 5.

Now the NB works great! According to the service ticket, they "repaired AGC circuit" (replacing three parts in the process), "re-aligned and updated the NB circuit", and "complete test and aligned to specs". All under warranty, of course. I am very pleased with Yaesu Service's work this time.

After having a couple of more months of 920 use under my belt, I have a couple of things I think should have been done differently or better on the 920:

Memory Management - When in memory mode, any change in mode, frequency, antenna setting, etc., puts the radio in a state called "M TUNE". Once in that mode, there is no knob you can turn or button you can push to take you to the next memory channel unless you press the "VFO/MEM" button first. This is very annoying. (on my TS-850, all you have to do is turn the "M CH/VFO CH" knob to go to the next memory)

Band Edge Limits - The 920 has only ONE pair of programmable band edge memories. Why? With 120 memories, surely Yaesu could have easily dedicated ten of them for this purpose, one for each band as in the FT-1000MP, TS-850, etc. This scheme should have been followed in the 920.

Narrow SSB Filter - I still think 920 could use the help of a narrower SSB filter. I am looking forward to Mark's review of the IRI 2.1 KHz SSB filter he's been talking about.

In my opinion, these are about the only areas in which this radio could have been improved.

The 920 is a great radio (even better now that the NB works!) which I plan to keep for a long time.

73, Jim, K5NTX (ex-KC5OA)

More Follow up comments from Jim

I thought you might want to post this somewhere in the FT-920 section of your web page to see if anyone else may have had a similar problem.

Last Monday I discovered that my FT-920's antenna tuner would no longer find a match on 20m. I also noticed that distinctive odor that burning electronic components emit coming from the rig after about 15 - 20 seconds of the tuner searching for a match. Within a few more seconds, the tuner shut down and the "High SWR" message appeared on the radio display.

My antenna is an R5 vertical which covers all bands from 20m thru 10m so I immediately tried the tuner on the remaining bands. 17m, 15m, and 10m were fine, but a match couldn't be achieved on 12m. So, both 20m and 12m were affected.

At this point I disconnected the 920 and tried two other HF rigs equipped with automatic antenna tuners. Each radio was able to achieve a match on all bands, 20m thru 10m. Obviously, the problem was in the 920.

I reconnected the 920 and operated the tuner on 20m several more times, smelled that smell again, and the tuner still couldn't find a match. After a few more tries, I let the radio sit, turned on but idle, for several hours and late that evening tried one more time. The tuner started out with high SWR showing but within a few seconds found a match with no problem. I then went to 12m and found the tuner to now be working properly on that band as well.

Everything has worked perfectly since. My guess is that a relay common to both 20m and 12m was stuck and eventually decided to started working again. I hope it's fixed itself -- this rig has been back to Yaesu twice in 15 months (NB mod and a subsequent related problem) and I sure don't want to have to send it again!

73, Jim, K5NTX

More follow up comments from Jim - 24 April 2000

Over the several months following my post about antenna tuner problems with my FT-920, tuner problems kept popping up. In general, one day it would decide not to tune on one or two bands while working fine on all the others. The next day, all would work fine and might continue to do so for a week or two. Then the problems with the tuner would start all over again. My other rig (a Kenwood TS-850SAT) had no problems whatsoever tuning the antenna. Bottom line was that I sent the rig back to Yaesu in late 1998, to let them correct the problem. When I got the rig back about six weeks later, it was accompanied by a note saying that even with the longer than normal testing they put the radio through, no problems were found with the tuner. To Yaesu's credit, they did this work for free even though the original one year warranty had expired.

My FT-920 made three trips to Yaesu in the 15-18 months following its purchase, with the first and third trips being busts (the botched NB fix, and failure to find the tuner problem, respectively). After giving Yaesu three shots at getting it "right" (four if you consider the original production of the radio), I decided that I'd had enough and sold it. Since then, I've acquired an Icom 756 and an Icom 775DSP (both of them used) and would not trade either of them for another FT-920, due to the less than satisfactory experience I had. However, I DO wish that the Icoms had the 920's variable DSP bandwidth control! It was without a doubt the best part of the 920.

73, Jim, K5NTX

WM7D dot Net - © Copyright 2017 , Mark A. Downing
Disclaimer: This site is in no way affiliated with or endorsed by Yaesu!