www.yaesu.com
The FT920 Resource Page
Last update: Monday, 10-Mar-2014 15:33:41 GMT

August 28, 1997

A couple of questions have come up in the past few days. First, did I solve the problem with the DVR? Yes and no. The DVR works just fine with the standard microphone. I just don't like that mic, and use an old Heil BM10 with the HC4 element. It has been my experience with this microphone, that it is just too hot for the radio. Heil told me to add 100ohms resistance in series with the mic element, and that did solve some of the over driving problem. However, I think that 100ohms is not enough. It did give me the ability to use the mic with the FT920, but only barely. I will experiment with resistance values until I find one I like. Right now the mic is usable with the mic gain adjustable. Before, it was either too much gain (over driving the ALC) or not enough. There was no in between setting.

Second, I was asked about the SB200 amp with the FT920. It works just fine, but the ALC is not compatible. I have used the amplifier for RTTY and SSB with no problems, as long as I keep the drive down. For RTTY (in this past contest), I was running the amp at 250-500w with 25-50w drive. Did not experience any difficulties with the amp or the radio running hot. For SSB, I run about 500w out with 50w drive. I have worked about 15 new countries in the past few weeks with this combination, and again, no difficulties. The FT920 has a nice feature that allows you to set the maximum power output to an antenna connection, but I am not currently using it. I have all my HF antennas connected to the A connector, and my 6m antennas connected to the B connector. There have been times that I have actually overdriven the amp because of this setup, but it seems to be the best way to deal with all of my antennas at the moment.

August 27, 1997

Been having a lot of fun with the FT920 the past few days as conditions have been good all over the world. Mainly working phone, and a little RTTY. The power problems I had experienced seem to have gone away. I decided to bite the bullet, and try full power in RTTY mode with no problems in my QSO with Brazil.

Two things to comment on: First, there seems to be a lot of speculation about the MARS mods... I have heard directly from Yaesu on this. The MARS mods can only be done with a firmware change at the factory.

Second, the SSB filter from INRAD may yet happen. I am not going to speculate on this any further until INRAD says FIRMLY that it will or will not be made available.

August 24, 1997

Just found out that the SSB filter is not going to happen. The problem lies in that you must remove the stock filter which is soldered in. This could be difficult, as you would have to remove the circuit board. Not something I would recommend at this time.

However, the CW filter will probably ship next week. Pricing and availability can be confirmed from International Radio (INRAD). See www.qth.com/INRAD for phone and address information.

I hope to have my CW filter something next week, and will offer more information at that time.

August 21, 1997

UPDATE: I received an email from Yaesu shortly after today's entry, and was told that a third party would be providing other filters soon. I have just received word from that third party that there will indeed be a 2.1khz SSB filter, and ALSO a 400hz CW filter. Pricing is not yet available, but I will put it here as soon as they tell me what the firm pricing will be. The CW filter should be available in a few weeks, and the SSB filter around the end of October.

I will make more information available as I get it. Expect pricing information in a few days, along with contact information.

August 21, 1997

I have received several messages in the past few days from people concerned about the problems I have had with my radio. Just to make things clear here, I am extremely happy with the FT920, and have no regrets about the purchase. Yaesu has told me that there have been no reports of serious problems with the FT920, and I have no reason to doubt them.

All of the "problems" I have had are minor, and (in my opinion) should be expected from a newly designed radio. As more radios are produced, there will be refinements to the design, and by now the radios will be pretty stable. Remember that my radio was purchased less than a week after it was made available in stores.

In summary, the problems were as follows:

  1. Crosstalk between the noise blanker, and the audio monitor.
    • Easily fixed by Yaesu, or you can just turn down the audio monitor pot.
  2. Problems getting the dual watch to work properly.
    • This was an operator error. I needed to reread the manual and turn up the squelch.
  3. Problems recording a message with the CW memory keyer.
    • Change menu U20 to EL2 for recording, and back to EL1 for sending.
  4. Couldn't get AFSK RTTY to work.
    • Problem is in the manual. The DATA[USB] mode is AFSK and DATA[LSB] is FSK.
  5. Antenna tuner malfunction.
    • The connector between the motor, and the variable capacitor popped loose.
  6. Power output dropped off in FSK mode.
    • This is the only problem that I considered to be serious. However, Yaesu was unable to duplicate the problem, and I have been hesitant to try to reproduce it. The ideal solution is to run with less than 100w output.
  7. Miscellaneous errors in the manual.
    • Yaesu has stated that there will be an addendum printed, and that these corrections will be added to the manual when there is another printing.
  8. The last item that I think could be a problem, is the lack of optional filtering.
    • The radio has only two optional filters. A 6kHz filter for AM, and a 500hz CW filter. The DSP does a good job for most needs, but there are times when the AGC gets overloaded due to strong signals nearby. This has become very noticable to me as I get more involved in contesting. The 500hz CW filter will solve my problems with RTTY, but there have been time that a narrower IF for SSB would be nice.

I feel that the list of problems above it relatively short for such a new radio. There has only been one problem (the power loss) that prompted me to take the radio to Yaesu for service. The antenna tuner problem was easy to fix, and was probably due to assembly problems.

Anyone else with an FT920 that wishes to send me some of their thoughts for this page? I'd sure like to see what others think as well.

August 18, 1997

The SARTG RTTY and NAQP SSB contests were held this weekend, and I did get to participate a little, but not nearly as much as I would have liked. The first objective of the weekend was to get my beam in the air. That accomplished, it was time to get on the radio.

Started the weekend with the RTTY contest friday night. Had a little fun, and enjoyed working 40/80m. 40 and 80 were far better this time around than during the NAQP contest. Probably because there are no such power limits during the SARTG contest. I ran the FT920 at about 25-35w out, into my SB200 for about 250w-350w into the antenna. Friday night was strictly a vertical antenna night.

I noticed that the 920 was a little warm to the touch on the back, next to the vent for the internal fan. Two things I need to do here. Yaesu suggested a muffin fan to help cool the radio. I thought I had a spare lying around, so I didn't buy another. It will be purchased before the CQWW contest. Also, I think I will get one for my amp. The amplifier did not act up at all this weekend (as a matter of fact, it has never given me trouble) but a little extra cooling never hurts any tubes.

Another thing I meant to do was pick up the 500hz if filter. Due to the efforts in raising my beam, I didn't get up to the candy store saturday. And I was unable to get back to the second stage of the SARTG contest as well. However, sunday morning, I did participate in the last 2 1/2 hours of the contest, and had a ball. The radio performed flawlessly, and I had fun. I will admit that I was not willing to run the radio at 100w in FSK mode because of the previous problems I had.

There was one other thing that I thought was strange after I got the radio back from Yaesu. The antenna tuner started doing strange things again. It continued to work fine on 80, 20, 17, 15, 12, 10, and 6m. The oddity came on 40m. Instead of bringing the SWR down, it was bringing it up. This is hard to describe... On all other bands, the tuner would immediately try to match the antenna and the SWR would start to go from say 2:1 down to 1.5:1 and then down to the final low SWR reading. On 40m, the tuner would go from 1.5:1 up to 3:1 or higher. Eventually, it would come down to near where it started, but it was far from ideal.

The solution was a simple one. I did a frequency and tuner reset, buy pressing the GEN and ENT keys, and turning the radio on. The tuner then started behaving as expected. I have no idea why this occured, but it doesn't appear to be a problem.

August 12, 1997

Picked up my FT920 at Yaesu this morning. They went thru the radio with a fine tooth comb, and then put the radio thru the weekend torture test. It has been in the cycling room since friday running one second on and one second off for about four days. As a matter of fact, the radio was still warm to the touch when I picked it up this morning.

So far, it looks like the radio is fine. In my discussions with Yaesu staff, we have come to the conclusion that it may have been a loose connection that was fixed when the radio was taken apart on friday. We also thought it was best to get the radio back to my environment to see if I can again duplicate the problem. But after three days of on/off cycling, the radio held up to a three minute full carrier transmit test. This is far better than I was experiencing last week.

The SARTG RTTY contest and NAQP phone contests are coming up this weekend, so I will be sure to give the radio another workout then.

August 7, 1997

Well, the FT920 has been dropped off at Yaesu's southern California office. It's sick, and the power output has started doing some strange things in FSK mode. I noticed it on Monday, when I was in a QSO with WB5B, and the radio just cut out. After calling Yaesu, I decided to try to duplicate the problem, and was able to see it happen three times. The radio worked fine for about 1.5 minutes before the power dropped off, and the transmitter cut out. It ran 100w and then started to drop off rapidly until it stopped transmitting. This happened in about a second.

Rekeying the radio resulted in a full 100w again, for about 1.5 minutes. I did not wait for any lengthy period as I wanted to finish my QSO, however I did check the radio to see if it was excessively hot. The fan was moving air, and the radio was warm to the touch, but not hot.

The odd thing is that the power would immediately come back up if I rekeyed the transmitter. It is as if the radio had a hidden time out timer, except for the power drop off. I would have never noticed the power drop off without my external power meter. The LCD meter on the radio showed no indication of RF power loss.

Hopefully the problem will be found and corrected in time for the SARTG, and the NAQP (phone) contests next weekend.

August 1, 1997

Turns out that I don't have to take the radio in after all. Called Yaesu this morning, and spoke with a representative who has helped me before. Don't know if he remembered helping me before, but he has a great attitude and is a pleasure to deal with.

Anyway, the rep suggested I look at the connectors to the capacitors in the tuner. Bingo. The plastic connector that connects the motor to the capacitor had come loose. A little adjustment, and tightening of a couple screws, and the tuner is working fine again.

Observation: The service manuals are finally available, and I'll get one next week.... but even without it, the radio seems to be straight forward. Of course there are things that I would not be to repair, but for accessibility, this radio is great. Lots of room to work, and the chassis is well thought out. To get to the tuner, you have to remove the top cover, and then a shielding panel (the speaker is mounted in it), and finally a shielding cover over the tuner. Very easy to figure out, and once I had the covers off, it was very easy to fix my problem.

Kudos again to Yaesu service! They have done a great job with nearly all of my problems.

WM7D dot Net - © Copyright 2017 , Mark A. Downing
Disclaimer: This site is in no way affiliated with or endorsed by Yaesu!