www.yaesu.com
The FT920 Resource Page
Last update: Monday, 10-Mar-2014 15:33:41 GMT

September 29, 1998

Yaesu's customer service surprises and amazes me again. I dropped off the radio yesterday, and left with an extremely good feeling. Hopefully the radio rapair will go just as well.

In all honesty, any time that I have had to deal with Yaesu, the support has been fantastic. My FT900 had a similar ALC problem about two years ago, was also repaired under warranty, and has not given me a bit of trouble since. As far as my FT920 is concerned, the original radio was in several times for repair (unfortunately, most of the trouble was operator error). Yaesu was able to fix the real problems, and seemed genuinely concerned about making sure that my radio worked properly. My experiences with other amateur radio manufacturers have not been quite so good.

September 28, 1998

I just got off the phone with Yaesu technical support, and they tell me that my radio is still under warranty. The discussion centered around some possibilities for the cause of the problem (perhaps a leaky cap). I will drop the radio off in Cerritos this afternoon, and will update this journal when more information is available.

September 27, 1998

The problem noted yesterday still exists. However, it only occurs AFTER the rig has been powered up for a few minutes. If I turn the radio on after it has been sitting for a while, I can get 100+ watts out on any frequency. I am pretty sure that this problem is directly related to the ALC circuit. Tomorrow, I'll find out what Yaesu has to say, and hopefully they will fix it for me. My hope is that it is simply an alignment issue, but the fact that it does not happen when the radio is cold worries me.

I did try to find a sevice manual yesterday, but none of the local shops have it in stock. I might pick one up at Yaesu's west coast office tomorrow.

Other than the 10m problem, my 920 is working well in the CQWW contest so far. I really could turn on the amp, and the low power output on 10m would be no big deal... it's just the principal of the thing {grin}.

September 26, 1998

Well, here is a new problem... While participating in the CQWW RTTY contest, I noticed that the power output on 10m seemed to be low. This was confirmed by transmitting into a dummy load. At 28080 the maximum RF output is 40 watts. At 28400, the RF output goes up to about 65 watts, and I do not see 100 watts until 28675. All other bands appear to be fine, but this anomaly is something I have not seen before.

I have tried reseting the microprocessor to no avail. It seems that this problem might be related to the ALC. I notice, upon checking the other bands, that the ALC drops off on 10m, but remains constant for all other bands. I wonder if there is an adjustment for the ALC level for each band. Perhaps I should look for a service manual today?

I will call Yaesu on monday, but I don't know how they will handle this. The radio is less than one year old, but the original purchase was made in May 1997. More to follow...

September 16, 1998

I have added photos from the 1998 Field Day excursion. There are a couple of pictures of my FT920 in it's operation position...

Still nothing of note to add. My 920 has been working perfectly. I had the opportunity to work Italy on 10m a week or so ago. It's nice to see that conditions are improving.

Just a thought while I am rambling.... I commented some time back on a problem I was having with RF getting back into my radio when I had some other equipment attached to the same power supply. Well, I finally found it. Turns out that I built a relay interface for isolating the keyline for my amplifier is the culprit. This simple little box was something I threw together a couple of years ago to use with my FT900 and a Timewave DSP. Seems that the FT900 did a better job of isolating the ground than my FT920 does, and there seems to be a problem with RF getting back in on the keyline. Oh well, I have since replaced that box with a solid state switch, and that RF problem is long since gone.

Also, I added a nice review from an SWL point of view. Thanks to Guy Atkins for this one.

WM7D dot Net - © Copyright 2017 , Mark A. Downing
Disclaimer: This site is in no way affiliated with or endorsed by Yaesu!